Status Update: CallRail Connectivity Issues

Incident Report for TapClicks

Resolved

We have successfully addressed the synchronization issue with the CallRail connector. Following a technical shift in how account identifiers were being returned from the vendor, we have updated our mapping logic to align with these changes.

Key Technical Updates
Identifier Shift: CallRail transitioned from alphanumeric company IDs (e.g., COM37eb...) to a 9-digit numeric format (e.g., 735338535).

Fetch Performance: We have confirmed that data fetches are now completing successfully and populating correctly into the system.

Mapping Restoration: Previously "no longer available" mapping lists are being updated to reflect these new IDs. If you haven't already done so, you may need to refresh your mapping list for the update.

Current Progress
Our engineering team has verified that the data flow is stable but will be monitoring in the next coming days.

If you are still experiencing issues with CallRail, please reach out to support@tapclicks.com
Posted Feb 13, 2026 - 22:21 UTC

Identified

Summary
We are currently investigating a widespread issue affecting the CallRail connector. While data fetches may appear to complete, the data is not being pulled properly into the system. This is causing existing mapping lists to display as "no longer available" across all connected instances.

Issue: Our team has observed a change in how account identifiers are being returned through the CallRail API.

Impact: This change affects the system's ability to match your existing configurations with the data currently being provided.

Scope: This is currently impacting all instances connected to CallRail. Historical data already loaded into TapClicks remains fine but you may observe discrepancies or prevented from retrieving newer data until this issue is resolved.

Next Steps: TapClicks is dependent on CallRail for updates and is coordinating with the CallRail technical team to reestablish our connection to the CallRail API.

Next Update: We will provide further information once the technical alignment between both platforms is finalized.
Posted Feb 13, 2026 - 19:45 UTC
This incident affected: TapAnalytics/TapReports.