Simpli.fi data Fetch Failures
Incident Report for TapClicks
Resolved
We have an interim solution in place to fetch Simpli.fi data via the API with Simpli.fi's recommendation by querying the data at a later fetch time (9 AM EST) when there is less traffic. We will be closing this post as fetches have been completed successfully but will continue to partner with Simpli.fi for future enhancements to optimize the fetch schedules.

If you continue to experience issues with your Simpli.fi data, please reach out to support@tapclicks.com.
Posted May 06, 2022 - 02:03 UTC
Update
We were provided some additional information from Simpli.fi about their reporting API updates. We have relaunched fetches for customers affected per Simpli.fi's recommendations and will continue to monitor the feed.
Posted May 04, 2022 - 22:00 UTC
Update
Simpli.fi is still investigating on their end regarding our connection to their API. Simpli.fi does not have an ETA on this but it’s actively being worked on and is a top priority for the Simpli.fi engineering department. We will post additional updates as they become available

Thank you for your patience as we continue to work through this with our partners at Simpli.fi.
Posted May 04, 2022 - 00:08 UTC
Update
As we continue monitoring Simpli.fi fetches, we are still noticing some intermittent failures. We have reached out to Simpli.fi for additional feedback for further assistance with their API. We will post additional updates as they become available.
Posted May 03, 2022 - 15:26 UTC
Monitoring
Simpli.fi has reverted some code changes on their end in regards to the suspected fetch timeouts. We are currently monitoring our fetches with the Simpli.fi API to see if the timeouts persist.
Posted May 02, 2022 - 23:36 UTC
Update
Our partner’s at Simpli.fi identified a deployment that went out on March 28th that is believed to be affecting the time it takes to return the API query results. Simpli.fi is currently in the process of addressing this on their end. We are currently awaiting further updates from the Simpli.fi team and will alert customers accordingly as information becomes available.
Posted Apr 27, 2022 - 19:46 UTC
Identified
Some customers may be experiencing issues with their Simpli.fi data fetches for large datasets with the Simpli.fi API. Our Technical team is currently working with our Partner at Simpli.fi for a path forward of addressing the API calls as an enhancement request for large datasets. If you are experiencing issues pulling Simpli.fi data via API, please submit a ticket to support@tapclicks.com if you haven’t already done so.
Posted Apr 25, 2022 - 18:27 UTC
This incident affected: TapAnalytics/TapReports and TapOrders/TapWorkflow.