Instagram Professional API change

Incident Report for TapClicks

Update

Fetches today continue to complete after close monitoring. We are marking the incident for fetch failures as resolved in the meantime.

We are still in the process of working with the new metric fields as an enhancement separately.
Posted Apr 24, 2025 - 18:24 UTC

Monitoring

Instagram has deprecated the "Impressions" field from the Professional API that was causing recent fetch issues. TapClicks has updated our system to discontinue requests for the impression metric to unblock data fetches for customers. Your historical impressions data that was previously stored within TapClicks will still be accessible in TapClicks but new impression data will no longer be supported by the Instagram API.

We will be working on introducing new fields per Instagram's recent changes.
Posted Apr 24, 2025 - 01:27 UTC

Identified

We are currently investigating an issue affecting the retrieval of recent metrics from the Instagram API. A recent change made by Instagram appears to be causing interruptions for some users attempting to access this data.

Our team is actively working to adapt to the update. We will provide further updates as more information becomes available.

Thank you for your patience and understanding.
Posted Apr 23, 2025 - 19:39 UTC
This incident affects: TapAnalytics/TapReports.