Potential Google API Data Delays

Incident Report for TapClicks

Resolved

Google has made an updated fix at 10PM UTC. We are now updating our status page accordingly as the fetches have been completing. If you are still observing issues with Google connectors, please reach out to support@tapclicks.com.
Posted Feb 03, 2026 - 16:48 UTC

Monitoring

Monitoring Google API Data Delays

Incident Status: Investigating
Affected Services: Google Ad Manager / Google Connectors

We are currently investigating an issue where data pulled from Google platforms via API may be delayed or incomplete. This is due to an ongoing service incident on Google’s side impacting reporting and API responses.

What customers may see:

Delays in Google data appearing in TapClicks

Failed or stalled data pulls for Google data services

Potentially Incomplete or missing metrics for recent reporting periods

Current status:

We've primarily seen this affecting Google Ads Manager and Google Analytics so far. Some other Google services api pulls may also be impacted. TapClicks systems are operating normally.

The issue originates from Google’s reporting infrastructure: https://ads.google.com/status/publisher/incidents/RauRLSuJsK5ZwApqdzEu
Our team is actively monitoring Google’s progress and will resume normal syncs once the service stabilizes

No action is required at this time. Data will backfill automatically once Google resolves the issue.

We will provide updates as more information becomes available.
Posted Feb 02, 2026 - 19:52 UTC
This incident affected: TapAnalytics/TapReports.