Twitter - Data Interruption Due to API Upgrade
Incident Report for TapClicks
Monitoring
TapClicks has pushed the updated code and data is beginning to flow in for any instances that experienced interruptions.

As a reminder, the previous Twitter V2 API that included Impressions, Clicks, and Video metrics on the Tweet level will render 0 until an alternative solution is coded and pushed.

TapClicks will plan to reinstate these metrics in a future release, when a more scalable solution against the V2 API is scoped and executed.

Thank you!
Posted Sep 10, 2021 - 19:02 UTC
Investigating
Customers leveraging Twitter data in their dashboards may have experienced a lag in data, particularly in regards to Tweet data. The issue stems from an API upgrade from the August release and the team is working to resolve the issue by reverting to the previous Twitter API Version.

TapClicks will revert the API version back to V1 to ensure legacy KPIs are updated in the system and plan for an alternative solution for the Twitter V2 API upgrade in the future. Once reverted, any recently exposed Tweet KPIs around Impressions, Clicks, and Video performance will reflect "0" values.

If you have any questions about this issue, please feel free to reach out to data-quality@tapclicks.com, customercare@tapclicks.com, or your Customer Success Manager.
Posted Sep 09, 2021 - 19:23 UTC
This incident affects: TapAnalytics/TapReports.