Google Analytics 4 New Property Type “App+Web”
Incident Report for TapClicks
Resolved
At this time, TapClicks will review any additional clients that need access to Google Analytics 4 data on a case by case basis. If you need access to this data set, please reach out to your Customer Success Manager or customercare@tapclicks.com

In the future when Google releases the Google Analytics Data API publicly, TapClicks will release the Google Analytics 4 connector to all clients.

Thank you!
Posted Feb 12, 2021 - 12:16 UTC
Update
Google Analytics 4 has been enabled for the second group of early access clients. We will continue to monitor the impact that increased traffic has on the pre-release Google Analytics Data API quotas.

Based on the outcome of that monitoring, we will review including additional clients on this pre-release connector in the coming weeks.

Please note that this API is "pre-release" and subject to change on the Google side with little, if any, notice. TapClicks will be monitoring this data connector so that should this occur, we make any changes within our control for as minimal interruption to data flow as possible.
Posted Feb 05, 2021 - 15:23 UTC
Monitoring
I'm happy to announce that the "Google Analytics 4 (early release)" connector was deployed with last week's patch. We are releasing this connector to clients in phases, the first group has access to this connector today and we will be releasing to the the next group with this week's patch. TapClicks is rolling this connector out in phases due to API Quota considerations.

As a reminder, this is a pre-release API from Google and subject to change without warning by Google. As such, please keep in mind that TapClicks will be monitoring the connector and will respond to any issues within our control as soon as possible.

If you have any questions, please feel free to reach out to your Customer Success Manager or customercare@tapclicks.com.

Thank you!
Posted Feb 01, 2021 - 15:38 UTC
Update
The team is working through a a few modifications to ensure that the new "Google Analytics 4 (early release)" is ready for users like you to leverage.

We are currently targeting this week's patch for deployment. Once the connector is live, instances that have been added to the early access list will be able to connect as early as Friday. Please note that based on our controlled roll out, this may not be available to your instance until early the following week.

When the connector is live, this page will be updated with the announcement.
If you have any questions about this project, please reach out to your Customer Success Manager or customercare@tapclicks.com.

Thank you!
Posted Jan 25, 2021 - 16:35 UTC
Update
I am pleased to share that the team is committed to exposing a version of this service with the upcoming January release. Once live in production, we will be enabling the new connector for clients with beta access within a few business days, allowing beta clients access to this data in their dashboards the week of January 25th.

As a reminder, this is a pre-release API from Google and is subject to the same breaking changes of an API that is not yet totally stable on the partner side. If you're interested in being a part of the beta group with access to this new connector, please let your Customer Success Manager or customercare@tapclicks.com know.

Thank you for your help and stay tuned for additional updates!
Posted Jan 11, 2021 - 17:17 UTC
Update
The engineering team is actively implementing a new Google Analytics 4 connector for TapClicks customers and I am confident that a solution option will be available in Q1. Once we have a more concrete timeline in coming weeks, I will share it here.

As this is a pre-release API from Google, upon release the TapClicks connector will be made available for those clients that have reached out with interest to their Customer Success Manager. If you're interested in being a part of the pool of clients with access to this new connector, please let us know (if you've already reached out as part of previous communications, we're including your instance for early access to this new connector).

Thank you for your help and stay tuned for additional updates!
Posted Dec 24, 2020 - 13:09 UTC
Update
The requirements for this project have been passed to the technical team for an effort estimate. I expect to have that next week and will share timeline targets here as soon as possible.

We are still looking for partners with "App+Web" properties to help our team drive development as quickly as possible. If you would like to help, please reach out to your Customer Success Manager who can inform you of next steps.

Thank you for your help and stay tuned for additional updates!
Posted Dec 10, 2020 - 20:25 UTC
Update
The team has evaluated a number of options to bring in data for "App+Web" properties from Google Analytics 4. We have selected a tentative path forward and we are writing requirements to move this project forward with engineering.

Once written, the solution proposal will be vetted for technical feasibility and scoped for effort. At that point, we should have an idea of a target release and will share updates here.

We are still looking for partners with "App+Web" properties to help our team drive development as quickly as possible. If you would like to help, please reach out to your Customer Success Manager who can inform you of next steps.

Thank you for your help and stay tuned for additional updates!
Posted Nov 19, 2020 - 19:50 UTC
Identified
Google Analytics has publicly released the new Google Analytics 4 platform which leverages a new Property Type, “App+Web”. Historically, Google Analytics properties were limited to the “Universal Analytics” type.

You have the ability to create new properties with the new type or you can upgrade the legacy “Universal Analytics” property type to the new “App+Web” type.

Before you move down this path, please note that once you have upgraded to “App+Web”, you cannot downgrade back to “Universal Analytics” and TapClicks does not yet have a connector with access to performance data from the new “App+Web” property type.


Why?
The legacy data for Google Analytics “Universal Analytics” properties come through the Google Analytics Core Reporting API Version 4 (https://developers.google.com/analytics/devguides/reporting/core/v4). The new “App+Web” data will be available from a new API that is currently in pre-release, the Analytics Data API (https://developers.google.com/analytics/trusted-testing/analytics-data).


What do I do?
TapClicks encourages you not to leverage the new property type for those entities that you need to report on within the TapAnalytics dashboard in the immediate to near term to ensure that your data continues to flow through the “Universal Analytics” property.

If you have already upgraded your properties or created new properties that you need for reporting, there is a way to export your data from Google Analytics 4 into Google Big Query, which Google describes here: https://support.google.com/analytics/answer/9823238?hl=en&ref_topic=9359001

Once your data is in Google Big Query, the TapClicks Smart Connector can bring that data into your reporting dashboard.


What is TapClicks doing about it?
We’re working closely with our Google contacts to understand when the Analytics Data API will be available publicly. In the interim, we’re looking to make as much progress on a new connector as we can ahead of the public release.

If you have any new “App+Web” properties and would like to partner with us to move this investigation forward, please reach out to your Customer Success Manager.

TapClicks will be updating this post as new information becomes available - if you have any questions at all, please don’t hesitate to contact us either through your Customer Success Manager or customercare@tapclicks.com
Posted Nov 09, 2020 - 18:59 UTC
This incident affected: TapAnalytics/TapReports.