X (Twitter) Ads Connector Outage

Incident Report for TapClicks

Resolved

X Ads have restored their API over the weekend and after monitoring, we can confirm a majority of customers fetches have been successfully completing.

We will close this incident as the connection now appears to be stable. If you are still facing issues with the X Ads connection, please reach out to support.

Thank you,
The TapClicks Team
Posted May 27, 2025 - 16:53 UTC

Identified

Description:
Tapclicks is currently experiencing an outage with the X (formerly Twitter) Ads Connector. This issue is due to an external service disruption on X Ads' side, which is impacting our ability to retrieve new advertising data via their API.

Impact:

New data from X Ads is currently unavailable in Tapclicks.

Previously imported data remains intact and accessible.

Next Steps:
We are monitoring the situation and awaiting further updates from X. We will provide additional information as it becomes available.

Thank you for your patience and understanding.
Posted May 23, 2025 - 16:00 UTC
This incident affected: TapAnalytics/TapReports.